The driver debugging
software instructions
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1 the software introduction and description

1.1 the Software introduction

The operating environment of the software is Windows 7 and Windows 10
operating system. It is suitable for all kinds of series inverters,used to debug
inverters, easy to modify parameters,and oscilloscope function to check the bus
voltage,output current and other parameters.This manual takes PH300 series
inverter as an example to explain each function item.

1.2 the Software function description

Open the folder where the software is located in [Inverter1.2.0],which contains
two folders  and [InverterP.exe] software.The Data folder stores data,and the
Lst folder stores configuration files and images used in the program.

ZFR BN HSE ESix) Fh
Data 2023-04-06 11:35 ST
Lst 2023-04-06 13:40 prgl=s
InverterP.exe 2023-03-21 11:42 NI FEFER: 6,921 KB

1) Open the [InverterP.exe] software main interface as follows:

P c odification -V1.2.0 = o X

<— Upper navigation bar
— Leftnavigation bar

hd UL 22000 Addr=1 x

Teal data
param list RealTime name Value RealTime name  Value
lmsoﬂ paran | ‘running frequency( 0.00 Set frequency (Hz) 50. 00
update param yap . N .
oscilloscope | bus Viotage(¥) 3206 out Viotage(V) 0
fault data out Cnrrent (A) 0.00 Output Torque (%) 0.0

output power (k¥) 0.0 S Input Flag 0

MOl Outpt Flag 0 FIV voltage(V)  0.03

FIC voltage (V) 0.02 Remaining time (M: 0.0

moreV¥ | FWD || Stop
adjustment (Hz) 10. 00 | Set v

current state current fault

serialsend 132 serial receive 131 serial overtime 0 72000_1 index= 0 Expanded 14:30:51

2) Top navigation bar function preview:

In [Edit], there are [serial portsetup], [device management], Desktop
display label], and [Exit].

In [Window], there are [Layout], [display Left frame], [fault Information].

In [Help],there are [About] and [Help].



Seting Window Help

serial port setup Window Help

device management Layout Help
Desktop display label display Left frame About
Exit { fualt infomation ly Help

Preview on the left navigation bar, the left navigation bar can perform real-time
monitoring, view parameter list, import parameters, operate
keyboard,oscilloscope, and fault record. The function is as follows:

~ Z2000 1

----- real data

----- param list

----- import param
----- update param
----- oscilloscope
----- fault data

2 Detailed description of each function

2.1 Device connection

Use the 485 serial cable to connect the device, the device is connected to the
RS+ and RS- ports, and the other end is connected to the computer via USB.

2.2 Edit

2.2.1 When using the software for the first time, you need to open the [serial
port setup] and modify the serial port number. If you do not know the serial port
number, you can view it in [My Computer] -> [Device Manager] -> [Port (COM
and LPT)]. After confirming the port. Baud, modify it in the software and click
[Open]. If the button is displayed as [Off], you need to click twice.



| ey

Port |COME v|Baud (9600 ~| oOff

a
=

(] show receive data. overtime (ms) 10
Save
B send not interval. set time (ms) 900
(] show send data Clear receives 14484 Zero
(] Send Dec Send
B CRC chec

Use the lower left display to determine if the connection is successful. When the
connection is successful, the serial send and serial receive are increasing.The
connection is fail if serial overtime is increasing.

serial send 15483 serial receive 15482 serial overtime 0 SysSet file Close 14:31:12

2.2.2 Select a matching device type

Switch the device type in [Edit] -> [device management]. You can also modify
the device name here. After the modification is completed, click the [Modify]
button to save. After modifying the device type, you need to restart the software.

device management *

Panel display button

device name  Z2000 (Jmove the locati

: (Jdisplay REV

Modbus Add 1 gif position
- (Jdisplay P_RE

| Left: 200
device type |Z2000E v B (Jdisplay P_FW

Top: 280

] ] () free stop

@ Enable this device Height: 200
set frequenc

Width: 160

display gif ino show animation Vi.

Modify the gif te be show path in Letfanimat(l..5).gif

add update delete next debug window

After completing the above settings and modifications, you can use the software
to view the parameters, compare the actual values with the default values, and
modify the parameter values.



2.3 Window

2.3.1 Modify layout

Click [Window] -> [Layout], you can place the background image you want to
switch in the folder Lst,and fill in the name of the picture in the layout
window.You can also modify the desktop background color and switch between
Chinese and English. After editing, click [Save]. After saving, you need to restart
the software to implement the modification.

2.3.2 Click [Window] -> [display Left frame] to hide/show the left navigation bar.
2.3.3 Click [Window] -> [fault information] to check whether the inverter is
currently faulty. If it is faulty, display the fault information.

2.4 Help

2.4.1 If there are any problems during the use, you can click [Help] -> [About] to
call the software service.

about X
Converter Parameter Modification

monitoring software

service phone 13482339880

2.4.2 Click [Help] -> [Help] to view the applicable environment and usage of the
software.



Help

Yperating envirorment:Windows 7, Windows 10 operating system.

Commection steps:
Step 1 Connect the serial port.
Step 2 Add the device and select the device type.

Change the interface picture, save the picture under Lst
BK. jpg, replace it

Replace the application name: open SysSet.dll file with
Notepad, modify the name of Company="XIXXIXXX company”

The current wversion 1.0.1, lastest time 2019-05-11.You can
contact our company staff to get the latest version.

1. Support warious types of inverters (requires modify
database files).

2. Support serial port MODBUS RTU protocol.

3. Support monitoring of multiple units and multiple
inverters. That is to support the use of one computer to
monitor multiple and multiple inverters at the same time.
4. Support function code parameter upload and download,
parameter file import and export.

~




2.5 Left navigation bar function

2.5.1 View real-time parameters

The display is as follows:

Z2000 Addr=1 x

RealTime name Value RealTime name Value
running frequency( 0. 00 Set frequency(Hz, 50. 00
bus Vlotage (V) 324.3 out Vlotage(V) 0

out Cnrrent (A) 0.00 Output Torque(%) 0.0
output power (kW) 0.0 S Input Flag 0

MO1 Outpt Flag 0 FIV voltage (V) 0.03
FIC voltage (V) 0.02 Remaining time(M: 0.0

more¥  FWD Stop

adjustment (Hz) 10. 00 = Set m

current state current fault

You can modify the displayed real-time parameters, double-click the
parameter name, and set the parameters that the user needs to display. As
shown in the figure below, refer to the manual to change the title name, receive
address,and decimal places displayed.

update monitor parameter X

SRR Sl unning frequency (Hz)

read modbus address 28672

display dot 2 Save

2.5.2 View param list

You can select the parameter group, or click the left and right buttons to view the
parameters of the adjacent parameter group. red indicates that the current value
of the parameter does not match the default value.



Update parameter Z2000 device type:Z2000E Address=1 X

€€ |PB Swing Frequency, Fixed Lengtl V| B Find OutputData
F. Code ParametName Value Unit Default Max Min Property ParametTy
PB. 00 Swing frequencysetting mode 0 Hz 0 1 0 write
PB.01 Swing frequency amplitude 0.0 % 0.0 100.0 0.0 write
PB.02 Jump frequency amplitude 0.0 % 0.0 50.0 0.0 write
PB. 03 Swing frequency cycle 10.0 % 10.0 3000.0 0:1 write
PB.04 Triangular wave rising time ¢ 50.0 % 50.0 100.0 D write
PB. 05 Set length 1000 m 1000 65535 0 write
PB. 06 Actual length 0 m 0 65535 0 write
PB. 07 Number of pulses per meter 100. 0 100.0 6553.5 0.1 write
PB.08 Set count value 1000 1000 65535 1 write
PB.09 Designated count value 1000 1000 65535 1 write

The parameter value can be modified by clicking on the current value of the
parameter. The modification takes effect after closing the window for modifying
the parameters.



Operation panel Z2000 device type:Z2000E Address=1 X

| F. Code PB. 01 KL >>>
param valueyg 0.0 % modifiable
Max: 0.0 Min: 100. 0 edit database
0. 0%~100. 0%
|Swing frequency amplitude default: 0.0

Click [edit database] to modify the parameters of the parameters and
modify the default values, units, maximum values, and minimum values. Click
[Refresh] after modification.



| [;} update database record X

F. Code PB. 00 short name Swing frequencysetting mode

| Address 64236 [JHEX unit |Hz v‘ property

| O modified
| default 0 dot place0

(O Shutdown cha
l (J study param
Max: 1

(I model dependen Uonly read

Min: 0 [ factory corr Uonly write

| detailDesc: update add

|0: Relative to the central frequencyl: Relative to the maximum
frequency

2.5.3 Import param

When you need to modify multiple parameters at the same time, you can
rganize the parameters into a txt file. Place the file in the Data folder,click [open
file], and select the file you want to import. After importing, click execute].

[ Z2000E When Read numbuer is less than the total, please wait X
‘ output ZC format ¥ [JOutput modified parameters St“dy paraial .
[ factory corrected: 0
| Parameter total: 364 Read number: 245 B ciodel dependent: 17
'RecF.Code ParameterName Value¥ Default Uni-Max val Min val Property ParametTyoutputV I
L C0.00 Speed/Torqgue control sele 0 0 1 0 stopWrite N
2 (€0.01 Torque setting source int: 0 0 7 0 stopWrite v
'3 €0.03 Torque digital setting in .- 150.0 % 200.0 —200.0 write
‘ 4 (€0.05 Forward maximum frequency —. — 50. 00 Hz 320.00 0.00 write
|5 (€0.06 Reverse maximum frequency —.-— 50. 00 Hz 320.00 0.00 write
‘ 6 C0.07 Acceleration time in torg —.-— 0.00 s 650. 00 0.00 write
7 C0.08 Deceleration time in torq —. - 0. 00 s 650.00 0.00 write
8 C5.00 PWM switchover frequency ' 8.00 8. 00 Hz 15.00 0.00 write N
9 C€5.01 PWM modulation mode 0 0 1 0 write v
10 C5.02 Dead zone compensation mo 1 1 2 0 write N
11 C5.03 Random PWM depth 0 0 10 0 write J
12 C5.04 Rapid current limit enabl 1 1 1 0 write N
13 C5.05 Current detectioncompensa 105 0 100 0 write o
14 C5.06 Undervoltage threshold se 350.0 70.0 YV 140.0 60.0 write ,
15 C5.07 SFVC optimization mode se.0 2 2 0 write J
16 C6.00 FI curve 4 minimum input 0. 00 0. 00 v 10.00 0.00 write +
17 C6.01 Corresponding setting of 0.0 0.0 % 100.0 -100.0 write N
18 C6.02 FI curve 4 inflexion 1 in 3.00 3.00 vV (C6.04 0.00 write v
19 C6.03 Corresponding setting of ' 30.0 30.0 % 100.0 -100.0 write v
20 C6.04 FI curve 4 inflexion 2 in 6.00 6. 00 v 10.00 0.00 write Vv

File template description:
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EF REE B0 ZFEV) #EBH
[SYS] ;
ModeType=PH300 (— Inverter type
Date=2019-11-05 13:09:18 (———— mpoOrt time
[Record]

Operation command channel selection=06F0020001

Frequency source superposition selection=06F0030002

Main frequency source x selection=06F0040002

Auxiliary frequency source y selection=06F0050008

I FWD terminal function selection=06F5000001
REV terminal function selection=06F501000A
S1 terminal function selection=06F5020008
S2 terminal function selection=06F5030012
S4 terminal function selection=06F5040025

PID given source=06FA000005 Command format:
PID feedback source=06FA020001 PID intial value=06FA150140

PID given feedback range=06FA042710 PID intial Value--param name
Proportional gain=06FA05005P/ e
PID initial value=06FA150140 06--write command

PID initial value holding time=06FA1607D0  FA15--operation on PA.15
0140--write value 140

Windows (CRLF) ZE 147, & 15 100%

2.5.4 update param

Simulate keyboard operation, select or fill in the function code, fill in the
value to be modified in the parameter value box, click the [Modify parameter]
button, the modification is completed, and the modification will take effect after
the window is closed.

| Operation panel 22000 device type:Z2000E Address=1 X
Switch function code left or right

F. Code PB. 01 e >

param valueyy 0.0 % modifiable

Update param value
Max: 0.0 Min: 100.0 edit database

0. 0%~100. 0%

Swing frequency amplitude default: 0.0
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2.5.5 oscilloscope

Select the parameters and gains to be displayed.A maximum of four
parameters can be displayed. Click CH1, CH2, CH3,and CH4 to select the
channel for recording.Modify the unit length,sampling interval,trigger
channel,and trigger value of the x axis as required.Then click [Start], and the
parameter change will start to be displayed in the coordinate axis. Select the
curve by frame to enlarge the curve. Select [Cursor] to draw two vertical scales in
the picture or switch to horizontal scales. The scale difference is displayed on
each channel.Click [Stop] torecord gain.

¥ CHL 4 CH2 < cEx B4 X iz 1000dot T| Trigger channel CH1 "| [

/AT Y v B 418 Start
: . it = Sangling Interwsl (100 Trigger walus 1.0
bur woltage Output frequency [7][Speed zeforence Fz[Output ouzzent (=  pyycg § ==
A
w0
L1
= =
] | | I
| | {
a6 | 1 |
¥ | =
7.5 | |
7 , |
L —
: / Y]
| f f
55 T Y T J
5 'I | II J
4B
I
35
3
5
15
1
o8
0
-1
15
k] | 2 3 1 8 ] 7 ] (]
o 4 cHz 4 cHI Bl % wxis [1000dot [z]  Trigesr channel (020 [] Stop
9 3,00 Bz 3,418 ¥ - |
i ot 24 - SapplingInterval 100 Trigger walus (00
bus weltags [=llpatput frequency [+][Speed reference Fr |Output current 2| yozon)pe an4 [
iy
L]
B85 T 23a
1
3 | | |
| |
(11 1 f

2.5.6 fault data
You can view the fault log, read the current fault of the drive, and clear all faults.
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ff fault query (] X

Clear fault fault find

NO deviceName fault inf State Time  displ Run Hz Curre Valtay I

3 Troubleshooting

If the debugging software fails, reconnect the serial cable to the computer. If
it still does not work properly, open [Monitor Serial Port] in [Settings].

Seting Window Help

I serial port setup I

device management
Desktop display label
Exit
| """ parail ListL | arvoes x ol
Check the display serial port to send data,view the data sent and received,and
find out the solution to the problem.

Port COM6 v |Baud (9600 ~| off @ X

[ show receive data. overtime (ms) 10
Save

B send not interval. set time (ms) 900

8 show send data Clear receives 10799 Zero

NotE 48.383 01 03 70 00 00 OC 5F OF
NotE 48.463 01 03 70 0C 00 OC 9F OC
NotE 48.535 01 03 70 00 00 OC 5F OF
NotE 48.625 01 03 70 0C 00 OC 9F OC
NotE 48.704 01 03 70 00 00 OC 5F OF
NotE 48. 778 01 03 70 0C 00 OC 9F OC
NotE 48. 836 01 03 F7 07 00 08 C7 B9

(] Send Dec
BCRC chec

Send
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4 Connect new devices

To connect to a new series, you need to switch the device type in [Edit] -> [device
management], click [Add] then restart the software.

5 Others

If you can't solve the problem, please contact the supplier or manufacturer for
processing, or call the software service phone in [Help]->[About]. Thank you!
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